<!DOCTYPE html>
<html lang="en">
<head>
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge">
  <meta name="viewport" content="width=device-width, initial-scale=1, user-scalable=no">

<link href="https://outline-prod.imgix.net" rel="preconnect" crossorigin>
<link href="https://im-dev-proxy.imgix.net" rel="preconnect" crossorigin>

<link href="/css/content-76205a462ac9675411a58d33bdc13823.css?vsn=d" rel="stylesheet" type="text/css">  <link rel="alternate" type="application/rss+xml" title="The Outline" href="https://theoutline.com/feeds/recent.rss" />
<link rel="icon" type="image/png" href="/images/favicon/pink/favicon-194x194-89224724481dc8d0efa135fcc4aef1dd.png?vsn=d" sizes="194x194">
<link rel="icon" type="image/png" href="/images/favicon/pink/favicon-32x32-51d2a9128c35821eae506c336486e97a.png?vsn=d" sizes="32x32">
<link rel="icon" type="image/png" href="/images/favicon/pink/favicon-16x16-1b624a5e4111ff9d82623870b8230534.png?vsn=d" sizes="16x16">

<link rel="apple-touch-icon" sizes="180x180" href="/images/apple-touch-icon-6abc580137cc97a42adde882e1ba60ec.png?vsn=d">
<link rel="mask-icon" href="/images/safari-pinned-tab-be282935e74cdc2f0462721ddf7e0139.svg?vsn=d" color="#5bbad5">
<meta name="theme-color" content="#ffffff">

<title>The Node.js world is imploding | The Outline</title>
<link rel="canonical" href="https://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech">

<meta name="description" content="Another programming community is having a meltdown due to festering sexism." />

<meta name="post_id" content="2206" />
<meta name="parsely-metadata" content='{"type":"post","post_id":2206}' />

<meta property="og:type" content="article" />
<meta property="og:site_name" content="The Outline" />
<meta property="fb:app_id" content="103730476786039" />
<meta property="fb:pages" content="527050847445390">
<meta property="article:publisher" content="https://www.facebook.com/outline" />
<meta property="og:url" content="https://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech" />
<meta property="og:title" content="The Node.js world is imploding" />
<meta property="og:description" content="Another programming community is having a meltdown due to festering sexism." />
<meta property="og:image" content="https://outline-prod.imgix.net/20170906-F1Dq8JMlAtZT6h37GFh4?auto=format&q=60&w=1280&s=555a7f558afa96721d91241e0e65d753" />

<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:site" content="@outline" />
<meta property="twitter:title" content="The Node.js world is imploding" />
<meta property="twitter:description" content="Another programming community is having a meltdown due to festering sexism." />
<meta property="twitter:image:src" content="https://outline-prod.imgix.net/20170906-F1Dq8JMlAtZT6h37GFh4?auto=format&q=60&w=1280&s=555a7f558afa96721d91241e0e65d753" />

<script type="application/ld+json">
{"url":"https://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech","thumbnailUrl":"https://outline-prod.imgix.net/20170906-F1Dq8JMlAtZT6h37GFh4?auto=format&q=60&w=1280&s=555a7f558afa96721d91241e0e65d753","publisher":{"name":"The Outline","logo":"/images/logo.svg","@type":"Organization"},"keywords":["The Future"],"image":"https://outline-prod.imgix.net/20170906-F1Dq8JMlAtZT6h37GFh4?auto=format&q=60&w=1280&s=555a7f558afa96721d91241e0e65d753","headline":"The Node.js world is imploding","datePublished":"2017-09-06T02:30:00Z","dateCreated":"2017-09-06T02:30:00Z","creator":["William Turton"],"author":["William Turton"],"articleSection":"The Future","@type":"NewsArticle","@context":"http://schema.org"}</script>

<script id="path-state" type="application/json">
{&quot;type&quot;:&quot;post&quot;,&quot;journey&quot;:{&quot;type&quot;:&quot;post&quot;,&quot;path&quot;:[{&quot;url&quot;:&quot;https://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech&quot;,&quot;type&quot;:&quot;medium&quot;,&quot;title&quot;:&quot;The Node.js world is imploding&quot;,&quot;styles&quot;:&quot;@media (min-width: 1280px){path-element[data-post-id=\&quot;2206\&quot;] .post__content .post__title{font-size:90px}}\n&quot;,&quot;social&quot;:{&quot;title&quot;:&quot;The Node.js world is imploding&quot;,&quot;description&quot;:&quot;Another programming community is having a meltdown due to festering sexism.&quot;,&quot;card_caption&quot;:&quot;Lead Art: Frankie Renlie&quot;},&quot;sensitive&quot;:false,&quot;path&quot;:&quot;/post/2206/the-node-js-code-of-conduct-diversity-tech&quot;,&quot;id&quot;:2206,&quot;html&quot;:null,&quot;description&quot;:&quot;Another programming community is having a meltdown due to festering sexism.&quot;,&quot;content_type&quot;:&quot;post&quot;}],&quot;next_micro_offset&quot;:0,&quot;microStep&quot;:3,&quot;location&quot;:0,&quot;hydrationLocation&quot;:0,&quot;features&quot;:{&quot;session_tracking&quot;:true,&quot;post_footer_type&quot;:&quot;default&quot;,&quot;gyro_background&quot;:false},&quot;enabled&quot;:true,&quot;cursor&quot;:&quot;/api/posts/v2/next_slice/future&quot;}}</script>
</head>
<body class="app ">

<main id="main" class="main">
  <path-root class="path ui-path-scroll">
    <div class="path__progress" data-index="0">
      <div class="path__progress__wrapper">
        <span class="path__progress__bar"></span>
      </div>
    </div>
    <path-plane class="path__plane">
  <style type="text/css">
@media (min-width: 1280px){path-element[data-post-id="2206"] .post__content .post__title{font-size:90px}}
  </style>
<path-element class="path__element" data-post-id="2206" data-post-type="medium">
    <div class="path__element__content">
<path-page
    class="page
           post
           post--layout-1
           post--color-scheme-2
           post--text-style-1
           post--embed-style-2
           color_filter--coral-blue
           card_type--bigdata"
    data-type="medium"
    data-color-filter="coral-blue"
    data-truncated=""
>
    <div class="post__card">
<div class="card
  color_filter--coral-blue
  filter_type--monotone
  text_color--color
  text_size--xsmall
  desktop_text_size--small
  card_type--bigdata"
  data-color-filter="coral-blue"
>
<div class="bigdata-card bigdata-card--1">
    <div class="bigdata-card__bg" data-color-filter="coral-blue">
<div class="card__bg__image">
<img src="https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=1280&amp;s=e4b5fdcc57a3cf8deff90b95c38150c3" srcset="https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=760&amp;s=31575826313ef3deefa328de308bac0c 760w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=960&amp;s=3bc4a40a98e201e416c47722927dd358 960w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=1280&amp;s=e4b5fdcc57a3cf8deff90b95c38150c3 1280w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=1400&amp;s=5dbf39d3d5bd6286293e6d36016bc85b 1400w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=1600&amp;s=abe68ece99ef2d1a5ed0bbc229368ed9 1600w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=2000&amp;s=f3de002f2880d862b581900aa732c84b 2000w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=2400&amp;s=3df5b03fb5ca28ce1d89da2394cbde72 2400w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3D183F63%26start%3D000000%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170906-NQI15LLUDdNMc88lpa2n%253F%2526s%253Dbf8766c3a34bbe0ee8e0faa13c2f727f?auto=format&amp;q=60&amp;w=3000&amp;s=4beeb177ecc462d384abc8b20c5316cc 3000w" alt="" />
</div>
    </div>

    <div class="bigdata-card__content">
        <h3 class="bigdata-card__eyebrow ui-transition-in--1">The Future</h3>

        <div class="bigdata-card__body">
            <div class="bigdata-card__number-wrapper">
                    <div class="bigdata-card__number ui-transition-in--1" data-spin="true" data-number="95" data-prefix="" data-suffix="%">
                        <span class="text">95%</span>
                    </div>
            </div>

                <div class="bigdata-card__description ui-transition-in--2">
                    <span class="text">The percentage of open source contributors who are men, a disparity that leads to fights over inclusivity like the one roiling the Node.js community</span>
                </div>
        </div>
    </div>
</div>
  <button class="card__cta card__cta--arrow">
    <span class="icon-arrowdown"></span>
</button>

<div class="card__link">
  <a href="http://opensourcesurvey.org/2017/#insights" target="_blank" rel="noopener">
GitHub    <span class="icon icon-externallink"></span>
  </a>
</div>
</div>
        <div class="post__card__share-container">
    <div class="post__card__share" data-button-count="4">
        <button class="navigation__menu__item post__card__share__toggle" type="button">
            <span class="icon icon-share"></span>
        </button>
        <div class="post__card__share__outlets">
            <a class="post__card__share__outlet" data-network="facebook" href="https://www.facebook.com/dialog/share?app_id=103730476786039&amp;display=page&amp;href=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech" target="_blank"><span class="icon-facebook"></span></a>
            <a class="post__card__share__outlet" data-network="twitter" href="https://twitter.com/intent/tweet?text=The+Node.js+world+is+imploding&amp;url=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech&amp;via=outline" target="_blank"><span class="icon-twitter"></span></a>
            <a class="post__card__share__outlet" data-network="email" href="mailto:?subject=The%20Node.js%20world%20is%20imploding&amp;body=You%20should%20really%20stop%20what%20you&#39;re%20doing%20and%20read%20this%20now:%0A%0AThe%20Node.js%20world%20is%20imploding%0A%0AAnother%20programming%20community%20is%20having%20a%20meltdown%20due%20to%20festering%20sexism.%0A%0Ahttps://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech"><span class="icon-mail"></span></a>
            <div class="post__card__share__outlet post__card__share__outlet--description" data-network="description">
              <span class="icon icon-info"></span>
              <div class="post__card__share__description">Frankie Renlie</div>
            </div>
        </div>
    </div>
</div>

    </div>
    <div class="post__content page__content">
        <header class="post__header">
            <div class="post__eyebrow">The Future</div>
            <h1 class="post__title">The Node.js world is imploding</h1>
            <h2 class="post__dek">Another programming community is having a meltdown due to festering sexism.</h2>
<div class="post__share">
    <div class="post__share__outlets">
        <a class="post__share__outlet" data-network="facebook" href="https://www.facebook.com/dialog/share?app_id=103730476786039&amp;display=page&amp;href=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech" target="_blank"><span class="icon-facebook"></span></a>
        <a class="post__share__outlet" data-network="twitter" href="https://twitter.com/intent/tweet?text=The+Node.js+world+is+imploding&amp;url=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech&amp;via=outline" target="_blank"><span class="icon-twitter"></span></a>
        <a class="post__share__outlet" data-network="email" href="mailto:?subject=The%20Node.js%20world%20is%20imploding&amp;body=You%20should%20really%20stop%20what%20you&#39;re%20doing%20and%20read%20this%20now:%0A%0AThe%20Node.js%20world%20is%20imploding%0A%0AAnother%20programming%20community%20is%20having%20a%20meltdown%20due%20to%20festering%20sexism.%0A%0Ahttps://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech"><span class="icon-mail"></span></a>
    </div>
</div>
        </header>

 <div class="post__article">
  <article class="post__wrapper">
    <div class="post__meta">

        <p class="post__authors">William Turton</p>

      <date class="post__date post__date--published">Sep&mdash;06&mdash;2017 10:30AM EST</date>
<div class="post__share">
    <div class="post__share__outlets">
        <a class="post__share__outlet" data-network="facebook" href="https://www.facebook.com/dialog/share?app_id=103730476786039&amp;display=page&amp;href=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech" target="_blank"><span class="icon-facebook"></span></a>
        <a class="post__share__outlet" data-network="twitter" href="https://twitter.com/intent/tweet?text=The+Node.js+world+is+imploding&amp;url=https%3A%2F%2Ftheoutline.com%2Fpost%2F2206%2Fthe-node-js-code-of-conduct-diversity-tech&amp;via=outline" target="_blank"><span class="icon-twitter"></span></a>
        <a class="post__share__outlet" data-network="email" href="mailto:?subject=The%20Node.js%20world%20is%20imploding&amp;body=You%20should%20really%20stop%20what%20you&#39;re%20doing%20and%20read%20this%20now:%0A%0AThe%20Node.js%20world%20is%20imploding%0A%0AAnother%20programming%20community%20is%20having%20a%20meltdown%20due%20to%20festering%20sexism.%0A%0Ahttps://theoutline.com/post/2206/the-node-js-code-of-conduct-diversity-tech"><span class="icon-mail"></span></a>
    </div>
</div>

    </div>
    <div class="post__body">
<p>A close-knit tech community has fallen into disarray over a debate that started around a Code of Conduct and quickly spiraled into a referendum on diversity initiatives.</p><p>Ashley Williams, an outspoken advocate for diversity in tech and a member of the Node Foundation Board of Directors, the volunteer leadership organization for the popular open source Node.js technology, is being accused of “hateful speech,” “promoting sex and race based prejudice and stereotypes,” and “promoting violence (homicide) towards men,” according to an <a href="https://www.reddit.com/r/node/comments/6whs2e/multiple_coc_violations_by_nodejs_board_member/">anonymous Reddit post</a> that rose to the top of the Node subreddit one week ago.</p><p>Williams, her anonymous critics say, is guilty of the very crime she has railed against: making the community, which is made up of more than <a href="https://github.com/nodejs/node/graphs/contributors">1,500 contributors</a>, less inclusive in ways that violate the community’s code of conduct. Her anonymous critic cited her tweets as evidence, including the time someone tweeted a photo of a contest at the security convention DEF CON with the sarcastic caption: “Hacker Jeopardy. Category is ‘Dicks’. Men play. Women give them beers. Why aren't there more women in security?" and Williams quote-tweeted them with the phrase “kill all men.” This was cited as “Promoting violence (homicide) towards men.”</p><div class="stack-embed stack-embed--display" data-headline="Gratitude" data-campaign="macallan_1"><div class="general-disclaimer"></div><p class="stack-embed__headline">Gratitude</p><div class="stack-embed__wrapper"><div class="card-stack card-stack--fan" data-length="3" data-type="display" data-campaign-slug="macallan_1" data-title="Gratitude" data-dfp-pixel="https://pubads.g.doubleclick.net/gampad/ad?iu=/264512349/theoutlinecom/macallan_product&sz=1x1&c=zyd1U7SklZBC0FEwhEy2"><div class="card-stack__container"><div class="card-stack__elements" data-type="display" data-campaign-slug="macallan_1" data-title="Gratitude"><a class="card-stack__element" target="_blank" data-index="0" href="https://us.themacallan.com/the-whisky/the-1824-series/rare-cask" data-redirect-url="/api/url-redirect?token=SFMyNTY.g3QAAAACZAAEZGF0YW0AAABmaHR0cHM6Ly9wdWJhZHMuZy5kb3VibGVjbGljay5uZXQvZ2FtcGFkL2Nsaz9pZD00MzczNTM0Nzc3Jml1PS8yNjQ1MTIzNDkvdGhlb3V0bGluZWNvbS9tYWNhbGxhbl9wcm9kdWN0ZAAGc2lnbmVkbgYArYU7WF4B.p5ZrO2EjOq_ftzHDaQ8wqoXDFhlh1y4fwrNgDQQcfv0"><div class="card-degraded"><div class="card-degraded__card quote-card-degraded quote-card-degraded--1"><div class="quote-card-degraded__bg"><div class="card__bg__image"><img class="display-target" src="https://outline-brand.imgix.net/macallan/display/Final-A1.jpg?fm=jpg&q=30&w=800?v=1" alt=""/></div></div></div></div></a><a class="card-stack__element" target="_blank" data-index="1" href="https://us.themacallan.com/the-whisky/the-1824-series/rare-cask" data-redirect-url="/api/url-redirect?token=SFMyNTY.g3QAAAACZAAEZGF0YW0AAABmaHR0cHM6Ly9wdWJhZHMuZy5kb3VibGVjbGljay5uZXQvZ2FtcGFkL2Nsaz9pZD00MzczNTM0Nzc3Jml1PS8yNjQ1MTIzNDkvdGhlb3V0bGluZWNvbS9tYWNhbGxhbl9wcm9kdWN0ZAAGc2lnbmVkbgYArYU7WF4B.p5ZrO2EjOq_ftzHDaQ8wqoXDFhlh1y4fwrNgDQQcfv0"><div class="card-degraded"><div class="card-degraded__card quote-card-degraded quote-card-degraded--1"><div class="quote-card-degraded__bg"><div class="card__bg__image"><img class="display-target" src="https://outline-brand.imgix.net/macallan/display/Final-A2.jpg?fm=jpg&q=30&w=800?v=1" alt=""/></div></div></div></div></a><a class="card-stack__element" target="_blank" data-index="2" href="https://us.themacallan.com/the-whisky/the-1824-series/rare-cask" data-redirect-url="/api/url-redirect?token=SFMyNTY.g3QAAAACZAAEZGF0YW0AAABmaHR0cHM6Ly9wdWJhZHMuZy5kb3VibGVjbGljay5uZXQvZ2FtcGFkL2Nsaz9pZD00MzczNTM0Nzc3Jml1PS8yNjQ1MTIzNDkvdGhlb3V0bGluZWNvbS9tYWNhbGxhbl9wcm9kdWN0ZAAGc2lnbmVkbgYArYU7WF4B.p5ZrO2EjOq_ftzHDaQ8wqoXDFhlh1y4fwrNgDQQcfv0"><div class="card-degraded"><div class="card-degraded__card quote-card-degraded quote-card-degraded--1"><div class="quote-card-degraded__bg"><div class="card__bg__image"><img class="display-target" src="https://outline-brand.imgix.net/macallan/display/Final-A3.jpg?fm=jpg&q=30&w=800?v=1" alt=""/></div></div></div></div></a></div></div></div></div></div><p>Codes of conduct are intended to protect underrepresented communities, like women, people of color, and LGBTQ people, and help set standards of behavior for the people who contribute to complex open source projects. The gender imbalance within the open source world, for example, is pretty extreme — open source contributors are 95 percent men, according to one <a href="http://opensourcesurvey.org/2017/#insights">survey</a>. Williams has <a href="https://youtu.be/H6cxY5zhFIA">frequently</a> given <a href="https://twitter.com/ag_dubs/status/776337983641378816">talks</a> and <a href="https://youtu.be/DN4yLZB1vUQ">presentations</a> about making the Node community more inclusive, and she believes codes of conduct are important for that. “These things are the bare minimum for successful communication among people,” she told <em>The Outline</em>. “It's really not meant to be a policing tool in any way.”</p><p>But now, Node’s Code of Conduct is being used against her. It’s important to remember that the controversy surrounding Williams didn’t start because a member of the Node community was having trouble working with her and filed a complaint, but because an anonymous Reddit user dredged up her old tweets and laid them out against selected portions of the code of conduct. (The author of the Reddit post used a throwaway account and declined to identify themselves in messages to <em>The Outline</em>, but said they actively contribute to the Node.js project.) The post about Williams is the most popular in the Node subreddit ever. And as her critics piled on, the leadership of Node has seemingly circled the wagons in what appears to be an effort to protect one of its own — not Williams, but another divisive member of Node leadership named Rod Vagg.</p><hr class="hr"/><p>The controversy started about two weeks ago.</p><p>Node isn’t owned by anybody; all of the source code is available for free online, and it’s used by major tech companies including <a href="https://www.youtube.com/watch?v=gtjzjiTI96c&list=PLfXiENmg6yyUpIVY9XVOkbdmBPx6PUm9_">Netflix</a>, <a href="https://nodejs.org/static/documents/casestudies/Nodejs-at-Uber.pdf">Uber</a>, and <a href="https://www.paypal-engineering.com/2013/11/22/node-js-at-paypal/">PayPal</a>. An army of volunteers work to improve Node and manage the developers who contribute to it. To that end, Node has multiple committees including a Board of Directors and a Technical Steering Committee, which recently merged with its Core Technical Committee. This infrastructure is necessary in order to manage such a large project.</p><p>Rod Vagg, a developer and member of the Core Technical Committee or CTC, had been involved in Node <a href="https://github.com/rvagg?tab=overview&from=2012-12-01&to=2012-12-31">since</a> 2012, which at the very least is a huge sacrifice of Vagg’s free time for no pay. But he was increasingly unpopular with a subset of the Node community.</p><blockquote class="pullquote pullquote--inline"><span>“...His bad behavior stems from ignorance and an unwillingness to learn.”</span><footer class="pullquote__attribution">— <cite>Bryan Hughes, who resigned his position on the Node Technical Steering Committee after a vote failed to remove a divisive colleague, Rod Vagg</cite></footer></blockquote><p>Members of the Node community filed multiple Code of Conduct complaints against Vagg, according to Williams’s tweets, saying he had been rude or aggressive, and that his often thousand-word long comments would derail discussion and make work less productive. The public claims against him, which have since been redacted, included Vagg’s <a href="https://twitter.com/rvagg/status/887652116524707841">implied support</a> of an “inflammatory anti Code of Conduct article” and contradicting action taken by moderators.</p><p>The complaints against Vagg led the 13-member Node Technical Steering Committee to call a vote on two things: whether to remove Vagg from the committee, and whether to ask him to step down voluntarily. Vagg and two other members did not participate in the vote, leaving 10 members to decide Vagg’s fate. On both proposals, six members voted in favor and four voted against, which meant Vagg got to keep his position.</p><p>The fallout had just started, however. The failure to remove Vagg seemed to trigger a meltdown in the Node community. Four board members stepped down after the vote: Anna Henningsen, Bryan Hughes, Myles Borins, and Jeremiah Senkpiel. “This is not about a specific individual, this is about the values we choose to demonstrate as a project and holding ourselves accountable,” Borin, a Google employee, wrote in his <a href="https://medium.com/@mylesborins/effective-immediately-i-am-stepping-down-from-the-nodejs-tsc-3df37c6ccbae">resignation letter</a>. “Rod had repeatedly shown a lack of judgement in how he acts within the project and with the broader community. He violated the Code of Conduct multiple times, and undermined efforts to increase inclusivity efforts at every step along the way,” Microsoft employee Bryan Hughes wrote in his <a href="https://medium.com/@nebrius/why-im-leaving-the-node-js-project-bff946845a77">resignation letter</a>. “I do not believe Rod did this intentionally, or that he is a bad actor in the classical definition. Rather, his bad behavior stems from ignorance and an unwillingness to learn. Rod’s intentions don’t really matter though. As they say, the road to hell is paved with good intentions.”</p><p>Around the same time, a group of concerned Node members split or “<a href="https://sourcecontribute.com/2017/08/22/node-js-has-forked-into-ayo/">forked</a>” the Node project, as an alternative version of Node but with new leadership. Alarmed, Marcus Hinkle, the executive director of the Node.js Foundation, urged the Technical Steering Committee to <a href="https://github.com/nodejs/board/issues/67">reconsider its decision</a> and “and suspend the individual involved from active TSC participation until this matter is resolved, hopefully with consensus, including support from those who recently resigned, if they would be willing to help.”</p><p>Vagg responded in a 4,700 word blog post titled, “The Truth About Rod Vagg.” “This caricature of me and vague notions regarding my ‘toxicity,’ my propensity for ‘harassment,’ the ‘systematic’ breaking of rules and other slanderous claims against my character has no basis in fact,” Vagg <a href="https://r.va.gg/2017/08/the-truth-about-rod-vagg.html">wrote</a>. “I will not dignify these attacks by taking tacit responsibility through voluntary resignation.” (Vagg declined to comment for this article. “I have received advice that I can't comment on the record about these matters with you unfortunately,” he said in an email.)</p><p>It’s unclear why the debate coalesced around Williams. Williams was not involved in the vote or the resignations, but she was a vocal critic of Vagg’s. In July, she tweeted that she had pushed for “<a href="https://twitter.com/ag_dubs/status/887782667902750721">sorely needed action</a>” against him behind the scenes.</p><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">rod and his constant, unproductive criticism of social policies in node is why i've drastically lessened my participation in the project.</p>— ashley williams (@ag_dubs) <a href="https://twitter.com/ag_dubs/status/887781671319334912">July 19, 2017</a></blockquote><script async="async" src="//platform.twitter.com/widgets.js" charset="utf-8"></script><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">beyond what he has done to the health of the project he also has specifically engaged in targeted harassment against me personally</p>— ashley williams (@ag_dubs) <a href="https://twitter.com/ag_dubs/status/887784337667653632">July 19, 2017</a></blockquote><script async="async" src="//platform.twitter.com/widgets.js" charset="utf-8"></script><p>Regardless, the anonymous Reddit post about Williams triggered the next phase in the Vagg/Node Code of Conduct fight. Node was now embroiled in a full-on internal culture war, with commenters degrading Williams, degrading Vagg, degrading diversity initiatives and the people who advocate for them, and debating the merits of Codes of Conduct. “It's truly sad that the platform that I once loved has turned out like this. It almost feels like a religious war with the CoC rules,” one commenter wrote. The thread became a forum for airing grievances against “social justice warriors” and lamenting the role gender and race have come to play in the discourse. “Everything must be viewed through the lens of how your gender makes you a victim,” one user wrote sarcastically. “But it's the other people who are sexists, you know, the ones who don't act like women need to be treated with kid gloves, and who judge a woman by her output.” “This is what you get when you play diversity politics instead of choosing the best person for the job based on ability. Eventually, any organization playing diversity games becomes unable to fulfill their primary function and it collapses,” another wrote.</p><blockquote class="pullquote pullquote--inline"><span>Node seems to be yet another tech community that harbors hostility toward diversity initiatives just under the surface</span></blockquote><p>Williams doesn’t know if a vote will take place to remove her from her position on the Node.js Foundation, or if she will be asked to step down. In a break from standard protocol, Node leadership <a href="https://github.com/nodejs/TSC/issues/324">publicly discussed</a> the complaint against Williams; before the thread was moved to a private discussion, multiple members of Node leadership seemed to agree that William’s dredged-up tweets constituted a violation of the Code of Conduct.</p><hr class="hr"/><p>A week has passed, and tensions seem to have cooled somewhat. The Core Technical Committee absorbed the Technical Steering Committee (a change that had been in the works before the Vagg vote) which mitigated the effect of the resignations. But there is still the sense that Node is yet another tech community that harbors hostility just under the surface toward diversity initiatives and the people who push for them. The dust-up mirrors what happened when engineer James Damore wrote a critique of Google’s diversity program that was leaked to the press. Damore’s memo was loudly denounced and its author fired, but internally and externally, many people supported his sentiments, which included fatigue, resentment, and the belief that diversity initiatives are pushing unqualified people into positions they don’t deserve. The controversy that hit Google and Node seems destined to repeat in more tech communities.</p><p>“My goal is to make Node as open as it possibly can be, and I really love the technology,” Williams told <em>The Outline</em>. “But there's always that moment where you have to ask yourself, is what I'm doing helping?”</p><div class="post-embed"><div class="post-embed__wrapper"><a class="post-embed__link" href="/post/1953/how-a-vc-funded-company-is-undermining-the-open-source-community"><div class="card
  color_filter--coral-blue
  filter_type--duotone
  text_color--color
  text_size--small
  desktop_text_size--small
  card_type--outline" data-color-filter="coral-blue"><div class="outline-card outline-card--1 outline-card--1--3-outlines"><div class="outline-card__bg" data-color-filter="coral-blue"><div class="card__bg__image"><img src="https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=1280&s=60cdb1861a80bb9c14e2c21bc298f8d1" srcset="https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=760&s=b897f9f7e641a262978450b66eb29511 760w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=960&s=d650f858485e544c9bff42ba5a40b0af 960w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=1280&s=60cdb1861a80bb9c14e2c21bc298f8d1 1280w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=1400&s=8adb758611c48ffa8ab3d4b2dcaeee2b 1400w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=1600&s=e9a61b0ec08c467ed82671bc5675c6c9 1600w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=2000&s=5508f5a59a962d0b2c340d98a20d795b 2000w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=2400&s=850b114412f062510196bba8aa41a3ce 2400w, https://im-dev-proxy.imgix.net/https%3A%2F%2Fd2poymsztgsqkb.cloudfront.net%2Fv1%2Fduotone%2Fpreview%3Fend%3DFB6754%26start%3D183F63%26url%3Dhttps%253A%252F%252Foutline-prod.imgix.net%252F20170721-J41NfJ385ByvBnYQZLB0%253F%2526s%253D2162fab45d147771403fabd5856d7c28?auto=format&q=60&w=3000&s=325fdff455d08ba7379fee29aa8186b5 3000w" alt=""/></div></div><div class="outline-card__content"><p class="outline-card__eyebrow ui-transition-in--1">Dark patterns</p><div class="outline-card__body"><div class="outline-card__line"></div><div class="outline-card__title-and-outlines"><h3 class="outline-card__title ui-transition-in--1"><span class="text">Open-source programmers are mad</span></h3><div class="outline-card__outlines"><div class="outline-card__outline ui-transition-in--2"><span class="text">San Francisco-based Kite took over the development of two popular open-source tools.</span></div><div class="outline-card__outline ui-transition-in--2"><span class="text">It made some changes that appeared to be self-serving and against the spirit of open source.</span></div><div class="outline-card__outline ui-transition-in--2"><span class="text">Now some coders are worried that the community has become vulnerable to bad actors.</span></div></div></div><div class="outline-card__line"></div></div></div></div><div class="card__cta card__cta--read-more">
  Read More
</div></div></a></div></div>
    </div>
  </article>

<div class="curiosity">
  <div class="curiosity__content">
    <h3 class="curiosity__title">Want something different?</h3>
    <div class="curiosity__items">
    </div>
    <div class="curiosity__newsletter">
      <form class="curiosity__newsletter__form newsletter-form" data-state="initial">
        <div class="newsletter-form__state" data-state="initial">
          <label class="curiosity__newsletter__form--label" for="email">
Get The Outline in your inbox          </label>
          <div class="curiosity__newsletter__form--fields">
            <input name="email" type="email" placeholder="your email here"
                   class="curiosity__newsletter__form--input newsletter-form--input"/>
            <button class="curiosity__newsletter__form--button">Subscribe</button>
          </div>
        </div>
        <div class="newsletter-form__state" data-state="success">
Fight the future.        </div>
      </form>
    </div>
  </div>
</div>
</div>

    </div>
</path-page>
    </div>
</path-element>

    </path-plane>
  </path-root>
</main>

<div class="navigation">
    <nav class="navigation__menu">
        <a class="navigation__menu__item navigation__menu__item--logo" href="/">
            <span class="icon icon-logo"></span>
        </a>

        <button class="navigation__menu__item navigation__menu__item--hamburger" type="button">
            <span class="icon icon-menu"></span>
        </button>
    </nav>
<div class="menu">
    <button type="button" class="menu__close-button">
        <span class="icon icon-close"></span>
    </button>
    <div class="menu__wrapper">
<h1 class="logo menu__logo" data-color="black">
    <a class="logo__link menu__logo__link" href="/">
        <span>The Outline</span>
    </a>
</h1>
        <div class="menu__links">
            <div class="menu__outmojis__wrapper">
                <a class="menu__link" href="/topic/recent">
Recent                </a>
                <a class="menu__link" href="/topic/power">
Power                </a>
                <a class="menu__link" href="/topic/culture">
Culture                </a>
                <a class="menu__link" href="/topic/future">
Future                </a>
                <div class="menu__outmojis">
                    <div class="menu__outmojis__set" data-set="1"></div>
                    <div class="menu__outmojis__set" data-set="2"></div>
                </div>
            </div>
        </div>
        <footer class="menu__footer">
            <div class="menu__social">
                <a class="menu__social__link" href="https://www.facebook.com/outline" target="_BLANK">
                    <span class="icon icon-facebook"></span>
                </a>
                <a class="menu__social__link" href="https://www.twitter.com/outline" target="_BLANK">
                    <span class="icon icon-twitter"></span>
                </a>
                <a class="menu__social__link" href="https://www.instagram.com/outline" target="_BLANK">
                    <span class="icon icon-instagram"></span>
                </a>
            </div>
            <div class="menu__footer__links">
                <a class="menu__footer__link" href="/about" >
About                </a>
                <a class="menu__footer__link" href="/legal" >
Legal                </a>
                <a class="menu__footer__link" href="https://boards.greenhouse.io/theoutline" target=&quot;_blank&quot;>
Jobs                </a>
                <a class="menu__footer__link" href="/tips" >
Got A Tip?                </a>
            </div>
            <span id="secret-code"></span>
        </footer>
    </div>
</div>
</div>

<script>
document.body.style.setProperty("--window-height", window.innerHeight+"px");
</script>

<script>
(function(d,e,j,h,f,c,b){d.GoogleAnalyticsObject=f;d[f]=d[f]||function(){(d[f].q=d[f].q||[]).push(arguments);},d[f].l=1*new Date();c=e.createElement(j),b=e.getElementsByTagName(j)[0];c.async=1;c.src=h;b.parentNode.insertBefore(c,b);})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create","UA-81610258-1","auto");
</script>

<div id="parsely-root" style="display: none">
  <span id="parsely-cfg" data-parsely-site="theoutline.com"></span>
</div>
<script>
  window.parselyPreload = { eventQueue: [], loaded: false };
  PARSELY = {
    autotrack: false,
    onload: function() {
        parselyPreload.loaded = true;
        for (var i = 0; i < parselyPreload.eventQueue.length; i++) {
            PARSELY.beacon.trackPageView(parselyPreload.eventQueue[i]);
        }
    }
  };
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
  e=d.getElementById(i), r=d.getElementById(p+"-root");
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = "https://d1z2jf7jlzjs58.cloudfront.net/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>

<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1016120788498657');
fbq('track', 'PageView', {referrer_domain: "direct"});


setTimeout(function() {
  fbq('track', 'Lead', {event_type: "time_5s", referrer_domain: "direct"});
}, 5*1000);
setTimeout(function() {
  fbq('track', 'Lead', {event_type: "time_30s", referrer_domain: "direct"});
}, 30*1000);

</script>
<noscript><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1016120788498657&ev=PageView&noscript=1" /></noscript>


<script type="text/javascript">
(function(e,t){var n=e.amplitude||{_q:[],_iq:{}};var r=t.createElement("script");r.type="text/javascript";
r.async=true;r.src="https://d24n15hnbwhuhn.cloudfront.net/libs/amplitude-3.0.1-min.gz.js";
r.onload=function(){e.amplitude.runQueuedFunctions()};var i=t.getElementsByTagName("script")[0];
i.parentNode.insertBefore(r,i);function s(e,t){e.prototype[t]=function(){this._q.push([t].concat(Array.prototype.slice.call(arguments,0)));
return this}}var o=function(){this._q=[];return this};var a=["add","append","clearAll","prepend","set","setOnce","unset"];
for(var u=0;u<a.length;u++){s(o,a[u])}n.Identify=o;var c=function(){this._q=[];return this;
};var p=["setProductId","setQuantity","setPrice","setRevenueType","setEventProperties"];
for(var l=0;l<p.length;l++){s(c,p[l])}n.Revenue=c;var d=["init","logEvent","logRevenue","setUserId","setUserProperties","setOptOut","setVersionName","setDomain","setDeviceId","setGlobalUserProperties","identify","clearUserProperties","setGroup","logRevenueV2","regenerateDeviceId"];
function v(e){function t(t){e[t]=function(){e._q.push([t].concat(Array.prototype.slice.call(arguments,0)));
}}for(var n=0;n<d.length;n++){t(d[n])}}v(n);n.getInstance=function(e){e=(!e||e.length===0?"$default_instance":e).toLowerCase();
if(!n._iq.hasOwnProperty(e)){n._iq[e]={_q:[]};v(n._iq[e])}return n._iq[e]};e.amplitude=n;
})(window,document);

amplitude.getInstance().init("5f5130f5178775d2873c84ccfa50df1a");
amplitude.getInstance().setUserProperties({
    "is_touch_device": ("ontouchstart" in window),
    "user_agent": "CCBot/3.0 (http://commoncrawl.org/faq/; info@commoncrawl.org)"
});
amplitude.getInstance().identify(new amplitude.Identify().setOnce("initial_referrer_domain", "direct"));
amplitude.getInstance().identify(new amplitude.Identify().setOnce("initial_path", "/post/2206/the-node-js-code-of-conduct-diversity-tech"));
amplitude.getInstance().identify(new amplitude.Identify().append("referrer_domains", "direct"));

</script>

<script>
window.onerror = function (msg, url, line_number, column_number, error) {
  var json = JSON.stringify({
    url: window.location.href,
    referrer: document.referrer,
    user_agent: window.navigator.userAgent,
    msg: msg,
    js_url: url,
    line_number: line_number,
    column_number: column_number,
    error: error,
    raf_override: (window.__raf_override === true)
  });
  var image = new Image(1, 1);
  image.src = "/api/analytics/js_error?json=" +  encodeURIComponent(json);
  return false;
};
</script>

<script src="/js/app_common-146d0be8788b9306fedb3e44c246bf4c.js?vsn=d" type="text/javascript"></script><script src="/js/content-db383232a44c19b4dc5f403084065ef8.js?vsn=d" type="text/javascript"></script>
<script async="async" defer="defer" src="/js/experiment-80d4fc3f24b605586752e973e358be77.js?vsn=d" type="text/javascript"></script>

<script>
window.addEventListener("load", function() {
  var scripts = [
    "https://platform.twitter.com/widgets.js",
    "https://platform.instagram.com/en_US/embeds.js",
    "https://www.youtube.com/iframe_api"];
  scripts.forEach(function(url) {
    var script = document.createElement("script");
    script.src = url;
    script.async = true;
    document.body.appendChild(script);
  });
});
</script>

</body>
</html>
